更多精彩文章请关注公众号『大海的BLOG』

Problem Description:

I have a very simple problem for you. Given two integers A and B, your job is to calculate the sum of A + B.

Input:

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases.
Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers
are very large, that means you should not process them by using 32-bit integer. You may assume
the length of each integer will not exceed 1000.

Output:

For each test case, you should output two lines. The first line is “Case #:”, # means the number of
the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B.
Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input:

2
1 2
112233445566778899 998877665544332211

Sample Output:

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

两种答法:
①:

#include<iostream>
#include<stack>
#include<strstream>
#include<string>
usingnamespace std;
int main()
{
int num;
cin>>num;
for(int i=0;i<num;i++)
{
int a,psize,qsize,n,m;
stack<int>zp;
stack<int>zq;
stack<int>z;
string p,q;
cin>>p>>q;
char*w=&p[0];
char*e=&q[0];
psize=strlen(w);
qsize=strlen(e);
for(int k=0;k<psize;k++)
zp.push(int(p[k])-48);
for(int k=0;k<qsize;k++)
zq.push(int(q[k])-48);
for(n=0;!zp.empty()&&!zq.empty();zp.pop(),zq.pop())
{
m=zp.top()+zq.top()+n;
if(m>=10)
{
z.push(m-10);
n=1;
}
else
{
z.push(m);
n=0;
}
}
if(zp.empty()&&zq.empty()&&n==1)
z.push(1);
else
{
if(!zp.empty())
{
for(;!zp.empty();zp.pop())
{
m=zp.top()+n;
if(m>=10)
{
z.push(m-10);
n=1;
}
else
{
z.push(m);
n=0;
}
}
}
if(!zq.empty())
{
for(;!zq.empty();zq.pop())
{
m=n+zq.top();
if(m>=10)
{
z.push(m-10);
n=1;
}
else
{
z.push(m);
n=0;
}
}
}
}
cout<<"Case "<<i+1<<":" <<endl;
cout<<p<<" + "<<q<<" = " ;
for(;!z.empty();z.pop())
cout<<z.top();
cout<<endl;
if(i!=num-1)
cout<<endl;
}
return 0;
}

②:

import java.util.*;
import java.math.*;
public class Main 
{
    public static void main(String[] args)
     {
        Scanner sc=new Scanner (System.in);
        int t=sc.nextInt();
        for(int i=1;i<=t;i++)
        {
            if(i!=1) System.out.println();
            BigInteger a,b;
            a=sc.nextBigInteger();
            b=sc.nextBigInteger();
            System.out.println("Case "+i+":");
            System.out.println(a+" + "+b+" = "+a.add(b));
        }
    }
}

更多精彩文章请关注公众号『大海的BLOG』


学习中...